XUTube Plugin www

Xlobby plugin development

Re: XUTube Plugin www

Postby dalanik on Thu Jun 14, 2007 8:48 am

dalanik wrote:Actualy, I'm having problems with it on 1 PC (my "production" HTPC!!!) as well, it is opening xtube object, but goes immediately to "replay this video" screen... hm, probably I don't have all updates on that PC...


This was solved by updating Flash player...

D.
dalanik
 
Posts: 886
Joined: Mon Apr 19, 2004 12:35 pm
Location: Prague, Czech Republic

Re: XUTube Plugin www

Postby dalanik on Thu Jun 14, 2007 8:50 am

cpa wrote:Here are a couple of problems.
1 - Any thumbnail I select will run the same video every time.
2 - The mouse does not work correctly in the youtube window that plays the video. when I click on the video screen lets say the pause button. It highlights in red but does not repond to the click. the same is true with all other video window related items.


Can you try this version:

http://xlobby.lanik.org/XUTube.v0.12b.exe

It genererates better HTML code...

D.
dalanik
 
Posts: 886
Joined: Mon Apr 19, 2004 12:35 pm
Location: Prague, Czech Republic

Re: XUTube Plugin www

Postby cpa on Thu Jun 14, 2007 2:35 pm

This one works properly. All the problems I wrote about are gone.
The only thing it needs to make it better is a video control feature.
cpa
 
Posts: 16
Joined: Sat Jun 09, 2007 4:57 am

Re: XUTube Plugin www

Postby dalanik on Thu Jun 14, 2007 4:20 pm

Yeah, only I didn't find a way to pause/ffd/rew/etc the video... it is not provided by the API... :-(
dalanik
 
Posts: 886
Joined: Mon Apr 19, 2004 12:35 pm
Location: Prague, Czech Republic

Re: XUTube Plugin www

Postby hvs69 on Tue Jul 03, 2007 6:29 am

I finally got some time to integrate your plugin into my skin :D

Here are some screenshots

utbe1.jpg

utbe2.jpg


For the life of me, I cannot get rid of the vertical scroll bar as evident in the above image. What is the trick ??

I also did find a small error in your utube.html file. There is an extra quote(") in the second line of code (shown below)

Code: Select all
<object width="425" height="350">"


I am not sure if that is responsible for the scroll-bar but if you look at the screenshot closely, you can see the extra quote.

Everything else works great. Thanks.
hvs69
 
Posts: 219
Joined: Wed Feb 11, 2004 8:06 am

Re: XUTube Plugin www

Postby dalanik on Tue Jul 03, 2007 8:32 am

Aha, I'll have a look in the source to get rid of the extra quote.

As far as the scrollbar is concerned, you really can't get rid of it - I did it by extending the explorer window in xlobby to fall out of the screen area for those 20 or so pixels (the width of the scrollbar), so it is still there, only it''s not visible because it's ouside of screen.

D.
dalanik
 
Posts: 886
Joined: Mon Apr 19, 2004 12:35 pm
Location: Prague, Czech Republic

Re: XUTube Plugin www

Postby dalanik on Tue Jul 03, 2007 9:23 am

OK, Should be fixed now (quote):

http://xlobby.lanik.org/XUTube.v0.13.exe

D.
dalanik
 
Posts: 886
Joined: Mon Apr 19, 2004 12:35 pm
Location: Prague, Czech Republic

Re: XUTube Plugin www

Postby hvs69 on Fri Jul 06, 2007 4:04 pm

Thanks for the updated plugin. Unfortunately, that did not fix the scrollbar.

There may be a solution...

In the RSS feeds, there is a field called "enclosure url"

If you pass that field to the browser object in xlobby, you will only see the youtube flashplayer.

The size of the browser will dictate the size of the flashplayer video object. If the aspect ratio of your xlobby browser is close to 4:3, you will not see any whitespace or scrollbars.

The problem is that the video does not autoplay. I tried to add &autoplay="1" but did not work. I thought that I had this figured out when I was writing this plugin but I cannot find the solution anymore. Maybe you can.
hvs69
 
Posts: 219
Joined: Wed Feb 11, 2004 8:06 am

Re: XUTube Plugin www

Postby dalanik on Sun Jul 08, 2007 8:58 pm

hvs69 wrote:Thanks for the updated plugin. Unfortunately, that did not fix the scrollbar.


No, the fix was only for the quote, not the scrollbar.

hvs69 wrote:In the RSS feeds, there is a field called "enclosure url"
If you pass that field to the browser object in xlobby, you will only see the youtube flashplayer.


Hmm, I'm not quite following... what do you mean to pass that field to browser?

D.
dalanik
 
Posts: 886
Joined: Mon Apr 19, 2004 12:35 pm
Location: Prague, Czech Republic

Re: XUTube Plugin www

Postby hvs69 on Mon Jul 09, 2007 5:25 pm

dalanik wrote:
Hmm, I'm not quite following... what do you mean to pass that field to browser?

D.


Under the browser, there is an xlobby event called "goto url". Normally you can use that to go to a specific website.

But, you can also use that to pass a URL from an xlobby database. So for example in your utube category, if you had a field called "url". You would type "%utube>url%" in the address field of the xlobby event, you essentially pass your "url" field to xlobby web-browser object. The requirement is that the xlobby screen should have a browser object (it will not open a new browser).

So, for example from Youtube RSS feed if you pass the enclosure url field such as:
http://youtube.com/v/QKXWAE8YYxY.swf
This will only open the flashplayer in the browser and the size of the player is controlled by the size of the browser window.

The problem is how do you make it autoplay ??
hvs69
 
Posts: 219
Joined: Wed Feb 11, 2004 8:06 am

Re: XUTube Plugin www

Postby Marbles_00 on Tue Aug 14, 2007 1:09 pm

dalanik,

I seem to be having a problem now with the category updating to the "popular" selection. When first going to my YouTube screen and select one of the most popular settings, it updates and displays in the category, but from there after if I select one of the other settings, I can see that my router and modem are getting updates (indicators are flashing for transmitting and receiving) but the category does not change.

If I exit xlobby and restart, then I can get the first update again.

I was using one of your previous versions...thinking that may have been a problem, I updated to the most recent, but still having this problem.

Any ideas?
Image
Mayhem Creations
where my:
    -Music Distribution
    -HTPC
    -MediaPVR
    -UnRAID box
    -OTA
are all discussed.

Xlobby Free Zone
Marbles_00
 
Posts: 1882
Joined: Wed Apr 06, 2005 12:44 pm
Location: Canada

Re: XUTube Plugin www

Postby dalanik on Wed Aug 15, 2007 8:33 am

Are you using latest pre-release or (old) free version of XLobby?
dalanik
 
Posts: 886
Joined: Mon Apr 19, 2004 12:35 pm
Location: Prague, Czech Republic

Re: XUTube Plugin www

Postby Marbles_00 on Wed Aug 15, 2007 12:55 pm

old "freeware" version...currently not enough interest in the new pre-releases.
Image
Mayhem Creations
where my:
    -Music Distribution
    -HTPC
    -MediaPVR
    -UnRAID box
    -OTA
are all discussed.

Xlobby Free Zone
Marbles_00
 
Posts: 1882
Joined: Wed Apr 06, 2005 12:44 pm
Location: Canada

Re: XUTube Plugin www

Postby Marbles_00 on Thu Apr 16, 2009 5:41 pm

Dalanik,

I'm integrating the xutube plugin into a new skin. Though I haven't mucked with it for a long while, now that I am, I'm not getting any videos to play. The thumbnail clips come in, but when I go to my video screen, the video doesn't playback. Has something changed with Youtube which may have broken the code? Or is it just me :shock:

Let me know.

Thanks in advance.

*EDIT*
Whoops...forgot to add an event with the Make_HTML command. Works now. One other thing, I can't seem to figure out how to get my own Developer ID (been so so long since the last time I got one...and I don't remember it). Anyway you could direct me? Right now I'm using your but I want to attain my own.
Image
Mayhem Creations
where my:
    -Music Distribution
    -HTPC
    -MediaPVR
    -UnRAID box
    -OTA
are all discussed.

Xlobby Free Zone
Marbles_00
 
Posts: 1882
Joined: Wed Apr 06, 2005 12:44 pm
Location: Canada

Re: XUTube Plugin www

Postby dalanik on Fri Apr 17, 2009 6:39 am

I created mine long time ago... :-) and it seems they have new api too (who cares if old one works) :-)

now it is associated with Google, try this:

http://code.google.com/apis/youtube/dashboard/developerSignup

D.
dalanik
 
Posts: 886
Joined: Mon Apr 19, 2004 12:35 pm
Location: Prague, Czech Republic

PreviousNext

Return to Plugins

Who is online

Users browsing this forum: No registered users and 2 guests

cron