7th Pre-Release Ready

Information related to the pre-release commercial version of xlobby

SOLVED

Postby thekochs on Sun Nov 04, 2007 2:35 pm

cmhardwick wrote:try this. Forget the (imho unnecessarily) long file name. Just leave it "collection.xml" Xlobby could be having some wierd problem with the long name or the spaces in it. Also, export it to c:\. Eliminate all those variables. Export DVD Pro to C:\collection.xml, set this as the XML in xLobby 7 (as you call it) and try the import.


I had that on my list to try today....I assumed not an issue because XL FREE has no problem with a long named spaced XML file name. However, XL Pre-Release 7 does !!! So, I found out that if you name it collection.xml you can place it in any directory...no problem. However, either XL PL 7 did not like the spaces or the length....or both...of my previous XML Profiler 3.x file name. When I changed to collection.xml, deleted DB, re-imported....bingo....all there. Maybe a bug Steven should look at ? Thanks for all the support/ideas.

Question, while I was doing this I went into XL Movie DB editor for first time and tried the download for info and covert art.....using movies.xlobby.com. Seem to work pretty good. So, I'm curious that other than I already have the DVD Profiler thing down....why would I not just use this XLobby editor download and scrap Profiler ? Only think I can think of is Profiler has HD covers....XLobby ? Also, know Profiler keeps the database (including coverart) in MyDocs folder. Where is/would be the XLobby info stored on import ? I know for coverart it points to the Profiler images....if I used XLobby coverart download instead where would these images be saved ?
thekochs
 
Posts: 155
Joined: Fri Dec 02, 2005 6:45 pm
Location: Atlanta, GA.

Re: 7th Pre-Release Ready

Postby cmhardwick on Sun Nov 04, 2007 3:20 pm

I wouldn't call that a "bug" since most everybody is going to accept the profiler export defaults. Why were you using such a long name anyway? The only difference between my export of movies and tv episodes (2 different databases) is the addition of tv to collections.xml.
Anyway...glad it's working.

The "why use dvdpro when xlobby dl seems to work well" that's just a personal choice on your part. I have no clue where it stores the coverart. The music spiders store coverart in the folder of the CD, don't know if this does that as well. I copy my coverart over to the DVD folder because that ways, it doesn't matter which machine I'm running from, the coverart path will be correct (it's a network share ... ie: \\mediasrva\movies\<moviename>\folder.jpg) The absolute path to the dvdprofiler images will ONLY work on that machine. If you only use one machine, no problem. I do my ripping, cataloging, etc, on my regular desktop machine then copy the database to my HTPC.
Cicero ... loving xLobby, both versions ... now just to get all the new toys ...
cmhardwick
 
Posts: 522
Joined: Fri Jul 14, 2006 6:07 pm
Location: Tennessee

Re: 7th Pre-Release Ready

Postby thekochs on Sun Nov 04, 2007 5:01 pm

cmhardwick wrote:I wouldn't call that a "bug" since most everybody is going to accept the profiler export defaults. Why were you using such a long name anyway? The only difference between my export of movies and tv episodes (2 different databases) is the addition of tv to collections.xml.


I would agree there is no real need but the description "collection" is kinda generic so I decided to make more descriptive. However, I would call this a bug in the sense only that XL FREE does not have this problem. Also, I could easily see many folks renaming the file name and as such this causes alot of confusion for such a simple item. Anyway, I'm glad it works and obviousy up to Steven to fix or not...clearly a small thing.
thekochs
 
Posts: 155
Joined: Fri Dec 02, 2005 6:45 pm
Location: Atlanta, GA.

Re: 7th Pre-Release Ready

Postby thekochs on Sun Nov 04, 2007 8:05 pm

Hey Guys,

I've moved my HTPC custom skin from XL FREE to XL PL7.....works great. This skin is a 1280x720 tweek of alot of skins. It's basic and centered around movies, music, pics and weather. I have some new backgrounds and mostly the screen layouts, navigation and buttons have gone thru a LARGE WAF (wife acceptance factor) effort. Thus, I'd like to share this with the community. How do I upload this skin for others to use ?

Also, quick question......in Steven's new default skin on startup he has some music playing. Like the idea....where is this located ?....I assume an Event tied to some mp3 or wav file ?

Regards.
thekochs
 
Posts: 155
Joined: Fri Dec 02, 2005 6:45 pm
Location: Atlanta, GA.

Re: 7th Pre-Release Ready

Postby cmhardwick on Sun Nov 04, 2007 10:42 pm

under the skin is a "startup" event that plays STARTUP.WAV located in the SOUNDS directory of the default skin. i THINK this event is in most of the skins automatically. To verify, just copy the SOUNDS from the default skin to your custom skin and see if it plays.
Cicero ... loving xLobby, both versions ... now just to get all the new toys ...
cmhardwick
 
Posts: 522
Joined: Fri Jul 14, 2006 6:07 pm
Location: Tennessee

Re: 7th Pre-Release Ready

Postby sharp_1 on Sun Nov 04, 2007 11:17 pm

thekochs wrote:I'd like to share this with the community. How do I upload this skin for others to use ?

Post some screen shots for us to look at along with links to your skin to we can download and take a look...you are not going to be able to access the xl server to load your skin to it but you can upload it to a free file sharing server like mediafire..thats what I use at least.
sharp_1
 
Posts: 633
Joined: Tue Jan 31, 2006 1:01 am
Location: Wisconsin

Re: 7th Pre-Release Ready

Postby cmhardwick on Sun Nov 04, 2007 11:27 pm

thekochs, I will host it for you, if you like. You've got my email, I'll work with you to get the file to me.
Cicero ... loving xLobby, both versions ... now just to get all the new toys ...
cmhardwick
 
Posts: 522
Joined: Fri Jul 14, 2006 6:07 pm
Location: Tennessee

Re: 7th Pre-Release Ready

Postby lpg on Mon Nov 05, 2007 1:31 pm

thekochs wrote:Hey Guys,

I've moved my HTPC custom skin from XL FREE to XL PL7.....works great. This skin is a 1280x720 tweek of alot of skins. It's basic and centered around movies, music, pics and weather. I have some new backgrounds and mostly the screen layouts, navigation and buttons have gone thru a LARGE WAF (wife acceptance factor) effort. Thus, I'd like to share this with the community. How do I upload this skin for others to use ?

Also, quick question......in Steven's new default skin on startup he has some music playing. Like the idea....where is this located ?....I assume an Event tied to some mp3 or wav file ?

Regards.

you could also use google. Set up a gmail account and get a free web page.

Larry
lpg
 
Posts: 314
Joined: Thu Apr 14, 2005 8:17 pm
Location: Chicago

Re: 7th Pre-Release Ready

Postby sharp_1 on Mon Nov 05, 2007 1:49 pm

lpg wrote:you could also use google. Set up a gmail account and get a free web page. Larry

Great idea!!!
sharp_1
 
Posts: 633
Joined: Tue Jan 31, 2006 1:01 am
Location: Wisconsin

Re: 7th Pre-Release Ready

Postby thekochs on Mon Nov 05, 2007 2:55 pm

cmhardwick wrote:under the skin is a "startup" event that plays STARTUP.WAV located in the SOUNDS directory of the default skin. i THINK this event is in most of the skins automatically. To verify, just copy the SOUNDS from the default skin to your custom skin and see if it plays.


Thanks, copied the sounds to my custom skin and sure enough it comes up on startup. However, I went into Events and I'm still learning how to use. I click on startup under skin and click on the few items there....no real commands I can see that would launch this WAV file. I highlighted each that was there and looked in right panel....nothing really showed up. Of course I'm sure it is pilot error on how to use. Quick insight/tutorial on what I'm missing ?
thekochs
 
Posts: 155
Joined: Fri Dec 02, 2005 6:45 pm
Location: Atlanta, GA.

Re: 7th Pre-Release Ready

Postby cmhardwick on Mon Nov 05, 2007 2:58 pm

there's nothing "intuitive" about startup events that I can find hehehe. It took me forever to get one setup that would fire off a macro on my powerhome server to update all the buttons on my "automation" screen with current status (on/off) and level if dimmed. And honestly, I really can't remember how I did it! lol
Cicero ... loving xLobby, both versions ... now just to get all the new toys ...
cmhardwick
 
Posts: 522
Joined: Fri Jul 14, 2006 6:07 pm
Location: Tennessee

Re: 7th Pre-Release Ready

Postby thekochs on Mon Nov 05, 2007 3:34 pm

cmhardwick wrote:there's nothing "intuitive" about startup events that I can find hehehe. It took me forever to get one setup that would fire off a macro on my powerhome server to update all the buttons on my "automation" screen with current status (on/off) and level if dimmed. And honestly, I really can't remember how I did it! lol


So, could you tell me what command in your Startup launches the WAV file ? I'm sure it is same for mine. Thx.
thekochs
 
Posts: 155
Joined: Fri Dec 02, 2005 6:45 pm
Location: Atlanta, GA.

Re: 7th Pre-Release Ready

Postby cmhardwick on Mon Nov 05, 2007 5:08 pm

the startup event group under skin has a "play audio" event attached to it. to my thinking this looks for a wave file named STARTUP.wav. If you click on that even, and click on the "triggers" on the right side, you should see it there.
Cicero ... loving xLobby, both versions ... now just to get all the new toys ...
cmhardwick
 
Posts: 522
Joined: Fri Jul 14, 2006 6:07 pm
Location: Tennessee

Re: 7th Pre-Release Ready

Postby thekochs on Mon Nov 05, 2007 9:24 pm

cmhardwick wrote:the startup event group under skin has a "play audio" event attached to it. to my thinking this looks for a wave file named STARTUP.wav. If you click on that even, and click on the "triggers" on the right side, you should see it there.


That is what I would have expected....no such luck. For XL PL 7 in default skin in Event tab under SKINS>STARTUP I see two events attached (meaning in tree structure below startup)........
at startup toggle > album open
set view text > save to variable

I don't see any "play audio". I do see the startup.wav in the Sounds directory which I copied....I see a startup2.wav too....I ran manually...kinda cool.

Again, I would think on the left is tree structure of all events running the skin with the command and parameters in the right panel. To be honest I've toggled thru alot of the events and don't quite grasp all the links to commands...I need to look at this more. BUT, as this example I'd really like to know how this plays since it does work (by just copying the WAVs).

Thanks.
thekochs
 
Posts: 155
Joined: Fri Dec 02, 2005 6:45 pm
Location: Atlanta, GA.

Re: 7th Pre-Release Ready

Postby thekochs on Thu Nov 08, 2007 11:29 pm

thekochs wrote:
cmhardwick wrote:the startup event group under skin has a "play audio" event attached to it. to my thinking this looks for a wave file named STARTUP.wav. If you click on that even, and click on the "triggers" on the right side, you should see it there.


That is what I would have expected....no such luck. For XL PL 7 in default skin in Event tab under SKINS>STARTUP I see two events attached (meaning in tree structure below startup)........
at startup toggle > album open
set view text > save to variable

I don't see any "play audio". I do see the startup.wav in the Sounds directory which I copied....I see a startup2.wav too....I ran manually...kinda cool.

Again, I would think on the left is tree structure of all events running the skin with the command and parameters in the right panel. To be honest I've toggled thru alot of the events and don't quite grasp all the links to commands...I need to look at this more. BUT, as this example I'd really like to know how this plays since it does work (by just copying the WAVs).

Thanks.


Any ideas on this guys ? I went ahead and looked in the SKIN editor for the Startup screen under Screen to see if there was a startup event that played this sound.....none found. So, either I'm missing something or in XL PL 7 the startup.wav file is harcoded to play on startup ? I'm hoping it is the former and my ignorance is not allowing me to see the obvious event that is running this sound.
thekochs
 
Posts: 155
Joined: Fri Dec 02, 2005 6:45 pm
Location: Atlanta, GA.

PreviousNext

Return to Pre-Release Area

Who is online

Users browsing this forum: No registered users and 1 guest

cron